Back to overview
Degraded

Login issues

Apr 17 at 05:48pm CEST
Affected services
Platform US
Platform EU

Resolved
Apr 17 at 06:26pm CEST

The issue has been resolved.

Created
Apr 17 at 05:48pm CEST

We're currently experiencing an issue where the login page isn't accessible for some users. Our team is investigating and working to resolve it as quickly as possible.